Plesk Obsidian upgrade Error occured while performing sub-action 'UpgradeZip' - Step by step guide to fix it ?







Sometimes Plesk Obsidian upgrade on Windows get's stuck or fails when trying to update to Plesk Obsidian 18.0.29.

Are you trying to fix "Plesk Error occured while performing sub-action 'UpgradeZip' "? We can help you.

Here at Ibmi Media, as part of our Server Management Services, we regularly help our Customers to fix related Plesk upgrade issues.


Nature of Plesk Upgrade error occurred while performing sub-action 'UpgradeZip'

When this error happens, you will see an error message such as this:

Upgrading Horde webmail...
Error occurred while performing sub-action 'UpgradeZip': Operation did not complete successfully because the file contains a virus or potentially unwanted software. (Error code 225) at copy file C:\Windows\system32\config\systemprofile\AppData\Local\Plesk\Autoinstaller\webmail4362\pear\pear\Horde\Test\vendor\phpunit\phpunit\src\Util\PHP\eval-stdin.php to C:\Program Files (x86)\Plesk\\Webmail\horde\pear\pear\Horde\Test\vendor\phpunit\phpunit\src\Util\PHP\eval-stdin.php


The main cause of this issue is:

#PPPM-12266 "Updating to Plesk Obsidian no longer fails with the "Operation did not complete successfully because the file contains a virus or potentially unwanted software" error." 

This issue was resolved in:

  • Plesk Onyx 17.8 07 September 2020 (Windows).
  • Plesk Obsidian 10 August 2020 (Windows).


How to fix Plesk Upgrade error occurred while performing sub-action 'UpgradeZip' ?

To resolve this error we can install Plesk updates or upgrade Plesk to the next release.


To Update Plesk via the Plesk interface, do the following:

  • Firstly we must ensure that port 8447 is opened in a firewall.
  • Then from Plesk, go to Tools & Settings, and click Updates and Upgrades.
  • And on the Updates and Upgrades page, click Update Components.
  • Now click on Continue to start the update.


To Update Plesk via the Plesk interface, do the below steps:

  • Firstly we must ensure that port 8447 is opened in a firewall.
  • Then from Plesk, go to Tools & Settings, and click Updates and Upgrades.
  • And on the Updates and Upgrades page, click Install or Upgrade Product.
  • After that, we need to select a Plesk version and click Continue to start the upgrade.


This will fix the Error occurred while performing sub-action 'UpgradeZip'.


[Need assistance in fixing Plesk errors? We can help you. ]



Conclusion

This article covers steps to fix Error occured while performing sub-action 'UpgradeZip' in Plesk. In fact, this is as a result of Anti-virus solution(s) blocking the Plesk upgrade process.


For Linux Tutorials

We create Linux HowTos and Tutorials for Sys Admins. Visit us on LinuxAPT.com

Also for Tech related tips, Visit forum.outsourcepath.com or General Technical tips on www.outsourcepath.com